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Who Should Use This Document
This user guide is intended to be used by any person who will install and work with the 
10/100 Internal PS for the ZM400 and ZM600 printers.

How This Document Is Organized
This user guide is set up as follows:

Section Description

Introduction This chapter provides a high-level overview of the 
10/100 Internal PS device, installation types, 
standard network configurations, and how to work 
with 10/100 Internal PS.

10/100 Internal Print Server This chapter provides you with details on the 
10/100 Internal PS features.

Getting Started This chapter provides you with information and 
procedures for working with the most frequently 
used 10/100 Internal PS features.

Installation This chapter provides information on the 
10/100 Internal PS, and how to install ZebraNet 
Utilities and the ZebraNet View Java Applet.

ZebraLink WebView on page 55 The appendix provides you with detailed 
information that allows you to use the enhanced 
functionality of your ZebraLink-enabled printer 
with the 10/100 Internal PS.

ZebraNet Utilities on page 93 The appendix provides you with details on 
ZebraNet Utilities, the software suite of printer 
administration tools that complements and 
enhances both ZebraLink and the ZebraNet family 
of connectivity products.

Hardware Troubleshooting 
on page 109

This appendix provides you with solutions to 
known issues.

Print Protocols on page 113 In this appendix, an exercise is provided to 
experiment with File Transfer Protocol (FTP) 
support.

Print Queues on page 115 This appendix provides information and 
instructions on configuring your print queue.

Frequently Asked Questions 
on page 119

This appendix provides a group of frequently 
asked questions (FAQs) about 10/100 Internal PS.

Glossary on page 123 This appendix is a list of terms and associated 
definitions.
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Contacts
You can contact Zebra Technologies Corporation at any of the following: 

Visit us at:  http://www.zebra.com

The Americas

Europe, Africa, Middle East, and India

Asia Pacific

Regional Headquarters Technical Support Customer Service Dept.

Zebra Technologies International, 
LLC
333 Corporate Woods Parkway
Vernon Hills, Illinois 60061.3109 
U.S.A
T: +1 847 793 2600
Toll-free +1 800 423 0422
F: +1 847 913 8766

T: +1 847 913 2259
F: +1 847 913 2578
Hardware: hwtsamerica@zebra.com
Software: swtsamerica@zebra.com

For printers, parts, media, and ribbon, 
please call your distributor, or 
contact us.
T: +1 866 230 9494
E: VHCustServ@zebra.com

Regional Headquarters Technical Support Internal Sales Dept.

Zebra Technologies Europe Limited
Zebra House
The Valley Centre, Gordon Road
High Wycombe
Buckinghamshire HP13 6EQ, UK
T: +44 (0)1494 472872
F: +44 (0) 1494 450103

T: +44 (0) 1494 768298
F: +44 (0) 1494 768210
Germany: Tsgermany@zebra.com
France: Tsfrance@zebra.com
Spain/Portugal: Tsspain@zebra.com
All other areas: Tseurope@zebra.com

For printers, parts, media, and ribbon, 
please call your distributor, or 
contact us.
T: +44 (0) 1494 768316
F: +44 (0) 1494 768244
E: mseurope@zebra.com

Regional Headquarters Technical Support Customer Service

Zebra Technologies Asia Pacific, LLC
16 New Industrial Road
#05-03 Hudson TechnoCentre
Singapore 536204
T: +65 6858 0722
F: +65 6885 0838

T: +65 6858 0722
F: +65 6885 0838
E: tsasiapacific@zebra.com

For printers, parts, media, and ribbon, 
please call your distributor, or 
contact us.
T: +65 6858 0722 
F: +65 6885 0837 

http://www.zebra.com
http://www.zebra.com
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Support

You can contact Zebra support at:

Web Address:  www.zebra.com/support

The Americas Phone Number  +1 847 913 2259

Europe, Africa, Middle East, India Phone Number  +44 (0) 1494 768298

Asia Pacific Phone Number  +65 6858 0722

Note • The web address is case-sensitive.

www.zebra.com/SS/service_support.htm
www.zebra.com/SS/service_support.htm
http://www.zebra.com/support
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Document Conventions
The following conventions are used throughout this document to convey certain information: 

Alternate Color  (online only) Cross-references contain links to other sections in this guide. 
If you are viewing this guide online, click the blue text to jump to its location.

Command Line Examples  All command line examples appear in Courier New font. 
For example, type the following to get to the Post-Install scripts in the bin directory:

Ztools

Files and Directories  All file names and directories appear in Courier New font. For 
example, the Zebra<version number>.tar file and the /root directory.

Cautions, Important, Note, and Example  

Caution • Warns you of the potential for electrostatic discharge.

Caution • Warns you of a potential electric shock situation.

Caution • Warns you of a situation where excessive heat could cause a burn.

Caution • Advises you that failure to take or avoid a specific action could result in physical 
harm to you.

Caution • Advises you that failure to take or avoid a specific action could result in physical 
harm to the hardware.

Caution • Advises you need to wear protective eye wear.

Important • Advises you of information that is essential to complete a task.

Note •  Indicates neutral or positive information that emphasizes or supplements important 
points of the main text.

Example • Provides an example, often a scenario, to better clarify a section of text.
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Illustration Instructions  Used when an illustration contains either information about a 
dialog box or step(s) to accomplish in a dialog box. 

One illustration instruction identifies a section of the dialog box and the other shows steps to 
follow.

Related Documents
The following documents might be helpful references:

• ZebraNet Wireless Print Server User Guide

• ZPL II® Programming Guide For x.10 through x.13 Firmware

• ZPL II® Programming Guide For x.14 Firmware and Above

• ZebraNet PrintServer II™ Installation and User Guide

1 Set Permanent text-box.
2 a. In the Set Permanent text-box, type in the print 

server’s IP address.
b. When you are finished, click OK.

1

2
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1
Introduction

This chapter provides a high-level overview of the 10/100 Internal PS device, installation 
types, standard network configurations, and how to work with 10/100 Internal PS. 
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Overview
The 10/100 Internal Print Server (PS) is an optional factory- or field-installed device that 
connects the network and your ZebraLink-enabled printer. 10/100 Internal PS provides you 
with a browser interface for printer and print server settings. If you use the ZebraNet Utilities, 
you can easily access the specialized features of a ZebraLink enabled printer. For details, see 
ZebraNet Utilities on page 93.

Components

Figure 1 shows the components of a printer equipped with a 10/100 Internal PS. Table 1 
identifies the various components and the functions each performs.

Figure 1 • Components

Important • You can download the most recent version of ZebraNet Utilities from 
http://www.zebra.com/printer_management.html.

21

http://www.zebra.com/firmware
http://www.zebra.com/id/zebra/na/en/index/products/printer_management.html
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Table 1 • Components and Functions

1 Printer with 10/100 Internal PS—10/100 Internal PS gives your printer 
these features:

• Print server and printer setup using a browser
• Remote monitoring and configuration capability of the 

10/100 Internal PS using a browser
• Alerts
• The ability for you to send unsolicited printer status messages via 

email-enabled devices
2 ZebraNet Utilities—ZebraNet Utilities is a suite of software programs 

that work with 10/100 Internal PS and enhance the features of ZebraLink 
resident within ZPL-based printers. The features include the following:

• ZebraNet View allows you to locate printers automatically. 
ZebraNet View searches on parameters such as IP address, subnet, 
printer model, printer status, and many other user-defined 
characteristics. It also offers powerful device management 
capabilities.

• ZebraNet Alert lets you configure multiple event alerts per device 
with different alerts directed to different people. You are notified 
of alerts from either visual or audio cues. You can also generate 
advanced alert reports.

• ZebraNet View Java Applet is a Java-based version of the popular 
ZebraNet View. It gives you ZebraNet View capabilities in a 
non-Windows environment.

• ZebraNet Connect IP allows you to discover a print server on a 
network and define a port for printing.
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Requirements
This section lists the minimum requirements for 10/100 Internal PS, which include firmware, 
software, browser support, protocols, and hardware.

Firmware 

For the ZM400 and ZM600, the appropriate firmware is 53.15 or above.

Software

These are the platforms supported by ZebraNet Utilities:

Microsoft® Windows® 95/98/Me/NT/2000/XP:
• Client mode for peer-to-peer printing via TCP/IP
• Print Protocols & Methods (all simultaneously active): 

• TCP/IP 
• LPR/LPD
• Telnet
• FTP
• Raw printer port (port 9100) 

The ZebraNet View Java Applet is supported by most Java-enabled browsers:

UNIX® Linux, and other systems supporting TCP/IP:
• Print Protocols & Methods (all simultaneously active): 

• TCP/IP 
• LPR/LPD
• Telnet
• FTP
• Raw printer port (port 9100) 

Browser Support
• HTML v3.2 or higher
• Internet Explorer or Netscape Navigator

Important • You can upgrade your firmware by visiting our web site: 
www.zebra.com/firmware

http://www.zebra.com/firmware
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Protocols
• TCP/IP: ARP, RARP

• TCP/IP & UDP: DHCP, BOOTP, SNMP v1.0

• HTTP v1.0

Hardware

The following are the 10/100 Internal Print Server options available for different printer 
models:

Compatibility
This section identifies the various components that are compatible with 10/100 Internal PS.

ZebraNet Wireless Print Server  10/100 Internal PS is fully compatible with the Wireless 
Print Server.

ZebraNet Wireless Plus Print Server  10/100 Internal PS is also fully compatible with 
the Wireless Plus Print Server.

Software  IBM®: Tivoli® v7.1.3, HP®: Web JetAdmin™ v7.0, OpenView™ v6.4, and any 
SNMP management application via Zebra Management Information Base (MIB) all work with 
10/100 Internal PS. 

Installation Types
10/100 Internal PS can be factory- or field-installed, as follows:

Factory  Factory installations are for new Zebra printers that are built with the 
10/100 Internal PS option.

Field  Field installations are for Zebra printers already in the field that do not have the 
10/100 Internal PS device installed. The 10/100 Internal PS option can be installed on existing 
printers, as follows:

• 10/100 Internal PS — this option connects directly to the main logic board

Printers External Internal
Field Upgrade

Internal
Factory

ZM400™ • • •

ZM600™ • • •

Caution • A qualified service technician must perform this installation.
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Technical Specifications for the 10/100 Internal PS

General Specifications

Network Connection Ethernet 10BaseT and 100BaseT UTP RJ-45 
connection Half and Full Duplex Communications 

User Interface A single (two element) LED activity indicator:
• bi-color display of operational status (solid 

green or solid amber)
• bi-color display of speed and network activity 

(flashing green or flashing amber)

Height (external dimensions) 0.5 in. 13.4 mm

Width (external dimensions) 2.2 in. 55.9 mm

Length (external dimensions) 3.7 in. 92.9 mm

Weight 0.9 oz 26 g

Temperature Operating 32° to 140°F 0° to 60°C

Storage –40° to 140°F –40° to 60°C

Relative Humidity Operating 20% to 80%, non-condensing

Storage 5% to 85%, non-condensing

Warranty Three years
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2
10/100 Internal Print Server

This chapter provides you with details on the 10/100 Internal PS features.
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10/100 Internal PS Features
This section covers features available for the 10/100 Internal PS only, not the printer’s 
features. Some of the features you access in this section prompt you to enter the default user 
ID and password, as follows:     

• User ID: admin

• Password: 1234 

Status and Configuration

The steps that follow are based on the navigation of a ZPL printer.

Important • You can upgrade your firmware by visiting our web site: 
www.zebra.com/firmware.

http://www.zebra.com
http://www.zebra.com/firmware
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To access the print server settings, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, and press Enter.
The Printer Home Page opens.

Figure 2 • Printer Home Page
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3. From the Printer Home Page, click Print Server Settings.
The Print Server Settings Page opens.

Figure 3 • Print Server Settings Page



2310/100 Internal Print Server
10/100 Internal PS Features

04/19/2007 ZebraNet® 10/100 Internal Print Server for ZM400 and ZM600 User Guide 14197L-001 Rev. A

4. From the Print Server Settings Page, click Print Server.
The Print Server Configuration page opens.

Figure 4 • Print Server Configuration

5. In the Print Server Configuration page, you have a menu from which to choose. Table 2 
identifies each menu option page.
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Table 2 • Menu Options

TCP/IP Configuration
You can change the TCP/IP configuration of 
the 10/100 Internal PS.
• IP Address: Use this feature to set the IP 

address if using the Permanent addressing 
method.

• IP Address Resolution: Use this feature to 
select the addressing method to use 
(Dynamic or Permanent).

• Dynamic Protocols: Use this feature to 
select the Dynamic Addressing method to use 
at startup. Choices include RARP, BOOTP, 
DHCP, Gleaning or Default Address.

• Subnet Mask: Use this feature to set the 
subnet mask. The subnet mask must follow 
the format XXX.XXX.XXX.XXX, where 
each XXX is a number between 0 and 255.

• Default Gateway: Use this feature to set the 
default gateway. This gateway will be used 
whenever messages need to be sent to 
another network. This gateway address must 
follow the format XXX.XXX.XXX.XXX, 
where each XXX is a number between 0 and 
255.

• WINS Server IP Address: Use this feature 
to set or view the IP address of the WINS 
Server.

• Connection Timeout Checking: Use this 
feature to enable or disable the Connection 
Timeout feature. The timeout is used to close 
network TCP/IP connections that are idle for 
more than the number of seconds entered in 
the Timeout Value.

• Timeout Value (secs): Use this feature to 
set the Connection Timeout Value. The Valid 
range is 10 to 3600 seconds. The default is 
300 seconds.

• ARP Broadcast Interval (mins): Use this 
feature to set interval for sending an ARP 
Broadcast. The valid range is 1 to 30 minutes. 
Address Resolution Protocol (ARP) 
broadcast packets allow other network 
devices to associate the print server's IP 
Address with its hardware address.

• Base Raw Port Number: Use this feature 
to set the raw TCP port that the print server 
will use for printing tasks. The default is port 
9100. 
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TCP/IP Logical Printing Ports
Logical printers allow you to set up multiple 
pre- and post-processing configurations for 
each output port. Each logical port 
configuration can perform the following:
• Add user-configured strings before and 

after the print data.
• Remove unwanted characters from the 

beginning of the print data.
• Four logical printer configurations are 

supported for each output port on the 
printer. The configurations can be assigned 
to any port, and all of these configurations 
can be assigned to a single output port.

Table 2 • Menu Options (Continued)
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System (SNMP)
This feature gives you the ability to manage 
multiple devices on a network, be it printers, 
computers, or other network-attached devices.
On this page, you can define the SNMP system 
name, system location (10/100 Internal PS 
description), and other SNMP settings for your 
10/100 Internal PS.

SMTP Email Alert Configuration
This feature allows you to enter data regarding 
System Information on the network that is 
being used. Typically, a Network 
Administrator would use this.

Table 2 • Menu Options (Continued)
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Web Admin
This page allows you to configure the Admin 
name and password. Links to upgrades and 
support information can also be altered. 
Note • The printer and print server password 
can be changed on ZPL printers with firmware 
53.15 or higher. 

POP3 Email Printing
This feature helps you set up the print server to 
receive email messages containing formats 
that can be printed. The POP3 settings must be 
set to retrieve emails from the email server. 
Important • Zebra recommends setting the 
POP3 polling interval no lower than 30. Some 
email servers will lock accounts after repeated 
login attempts.

Table 2 • Menu Options (Continued)
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Print Server Status

From the Print Server page in the Print Server Status section, you can access the 
10/100 Internal PS configuration sheet and port status.

To open the 10/100 Internal PS configuration page, complete this step:

1. From the Print Server Settings Page, click View Configuration Sheet.
The Configuration Sheet opens.

Figure 5 • Configuration Sheet
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 To view the port status, complete this step:

1. From the Print Server page, click View Port Status.
The Port Status page opens.

Figure 6 • Port Status

Important • The default user ID and password is required to access this page.
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Reset

From the Print Server page in the Reset section, you can perform a soft reboot of the print 
server.

To reset the 10/100 Internal PS, complete these steps:

1. From the Print Server Settings page, click Reset Print Server.
The Reset Print Server page opens.

Figure 7 • Reset Print Server

2. To reset 10/100 Internal PS, click Yes.
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Restore

From the Print Server page in the Restore section, you can restore 10/100 Internal PS to the 
default factory settings:

To restore 10/100 Internal PS to the default factory settings, complete these 
steps:

1. From the Print Server page, click Factory Print Server Settings.
The Restore To Factory Defaults page opens.

Figure 8 • Restore to Factory Settings

2. Make the selections you want, and click Submit Changes.
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3
Getting Started

This chapter provides you with information and procedures for working with the most 
frequently used 10/100 Internal PS features.
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Before You Begin
10/100 Internal PS offers many features, but how you access and work with them is dependent 
on your environment. Before you begin, you need to get information from the 10/100 Internal 
PS configuration label.

Table 3 shows the minimum label widths needed to print a 10/100 Internal PS configuration 
label with different DPI printheads.

To print a network configuration label for the ZM400 or ZM600 with a 
10/100 Internal PS, complete these steps:   

1. Turn on (I) the printer and let it complete its power-up cycle.
When the POST cycle is complete, press Setup/Exit to enter the Setup Mode.

2. Scroll through the parameters using the Plus (+ key) until you reach List Network.

3. Press Plus (+ key) to print the network configuration label.

Important • Make sure the printer is turned off (O).

Table 3 • Label Width

DPI Inches MM

600 1.25 31.75

300 2.50 63.50

200 3.69 93.73
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Figure 9 • Network Configuration Label for the 10/100 Internal PS for 
ZM400/ZM600
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4. Press Setup/Exit to exit the Setup Mode.

5. From the network configuration label, you need to look for these numbers:

• IP PROTOCOL

• IP ADDRESS 

• SUBNET MASK 

• DEFAULT GATEWAY 

• MAC ADDRESS 

6. On the network configuration label that prints out for your 10/100 Internal PS device, 
circle the aforementioned settings. You can now proceed to Assigning an IP Address 
on page 41.
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Using the Control Panel to View and Modify Print 
Server Parameters

You may change several print server parameters using the control panel on the printer. Table 4 
shows the parameters that may be viewed or modified through the printer’s control panel for 
printers with firmware version V53.15.x or later. (Printers with older versions of firmware 
have a different set of parameters.)

Table 4 • Print Server Parameters

Parameter Function

LIST NETWORK Print a Network Configuration Label
Use this parameter to print a network configuration label (see Figure 9 
on page 35).

IP PROTOCOL1 View the Method to Obtain an IP Address
This parameter tells if the user (permanent) or the server (dynamic) selects 
the IP address. If a dynamic option is chosen, this parameter tells the 
method(s) by which the print server (wired or wireless) receives the IP 
address from the server.
Selections: ALL, BOOTP, DHCP, DHCP AND BOOTP, PERMANENT
Default Value: All

IP ADDRESS1 View the Print Engine’s IP Address
Default Value: 0.0.0.0

SUBNET MASK1 View the Subnet
Default Value: 255.255.255.0

DEFAULT GATEWAY1 View the Gateway
Default Value: 0.0.0.0

RESET NETWORK1 Reset the Wired or Wireless Network
Use this parameter to reinitialize the wireless radio card and the print server 
(wired or wireless) when the wireless print server is running. This 
parameter also causes any wireless radio card in the printer to reassociate to 
the wireless network.

ACTIVE PRINTSRVR View the Active Print Server
Selections: Wired, Wireless
Default Value: Wired

PRIMARY NETWORK View the Primary Network
Default Value: Internal Wired

1  These parameters appear after the system recognizes the existence of a ZebraNet print server (wired or wireless). After the 
print server is recognized, all zeroes (000.000.000.000) will display until the printer obtains an IP address or defaults to 
address 192.168.254.254.
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Defaulting the 10/100 Internal PS
This section provides you with instructions for defaulting the 10/100 Internal PS to factory 
settings using the control panel, WebView, and ZebraNet View.

Control Panel

To default the 10/100 Internal PS to factory settings using the control panel, 
complete these steps:

1. From the control panel, press Setup/Exit two times.

2. Press Plus (+ key) five times.
The control panel will read DEFAULT NET.

3. Press Setup/Exit to save the change.

4. After the printer defaults all settings, the control panel will show PRINTER READY.
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WebView    

To default the 10/100 Internal PS to factory settings using WebView, complete 
these steps:

1. From the ZebraNet PrintServer view, click Factory Print Server Settings.
The Restore to Factory Defaults page opens:

Figure 10 • Restore to Factory Defaults

2. Enable the check box for the settings you want to reset, and click Submit Changes.

Important • During the reset cycle, the web pages are unavailable. Upon completion, 
check the IP address of the 10/100 Internal PS as it may have changed during the reset 
cycle. 
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ZebraNet View    

To default 10/100 Internal PS to factory settings using ZebraNet View, complete 
these steps:

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet View.
The ZebraNet View dialog opens:

Figure 11 • ZebraNet View

2. From the menu bar, select Print Server > Reset. 
The Reset Print Server dialog opens: 

Figure 12 • Reset Print Server

3. Select the settings you want to reset, then click Restore.



41Getting Started
Assigning an IP Address

04/19/2007 ZebraNet® 10/100 Internal Print Server for ZM400 and ZM600 User Guide 14197L-001 Rev. A

Assigning an IP Address 
Before you can begin working with 10/100 Internal PS, you must get or assign an IP address 
for the 10/100 Internal PS device.

There are four different ways to assign an IP address. Here is a list and a brief description of 
each method:

• Web View — Browser-enabled method to assign an IP address.

• ZebraNet View — Utility that remotely manages ZebraLink-enabled printers.

• DHCP — See your LAN administrator for more information.

• Telnet — DOS command to assign an IP address.

With Dynamic Host Configuration Protocol (DHCP) 

If your network uses DHCP, your 10/100 Internal PS device is assigned a temporary IP 
address.

 

Without DHCP 

If your network does not use a dynamic IP addressing system (such as DHCP), you need to set 
a permanent IP address for the 10/100 Internal PS device. ZebraNet View is the 
Windows-based print server management and configuration utility that comes with your 
10/100 Internal PS. 

Important • Throughout the procedures in this chapter, there are some features that require the 
default User ID and/or default password. If you are prompted, these are the defaults:

• User ID: admin
• Password: 1234

Note • Check with your Network Administrator to see whether your network uses DHCP. 

Important • The remaining sections are dependent on the successful installation of ZebraNet 
Utilities. To install, see ZebraNet Utilities on page 49.
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Assigning an IP Address with DHCP

To assign an IP address using ZebraNet View, complete these steps: 

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet View.

The ZebraNet View dialog opens:

Figure 13 • ZebraNet View

2. Compare the MAC Address on the 10/100 Internal PS network configuration label with 
the H/W Address column on the screen to find the 10/100 Internal PS you are working 
with. 

3. When you locate your 10/100 Internal PS, select it. 

4. From the menu bar, select PrintServer > Configuration.

5. If your 10/100 Internal PS does not have an IP address, complete these steps:

• Find your 10/100 Internal PS and right-click.

• In the small dialog that opens, enter an IP Address, click OK.

• The ZebraNet View dialog opens. 

Important • On the illustration that follows, take note of the H/W address column and 
Serial # column. Compare what you see in ZebraNet View with the network 
configuration label you printed out.

Important • If the 10/100 Internal PS does not have an IP address, it shows in the main 
screen with an IP of 0.0.0.0. If, after 2 minutes, you do not assign an IP Address, the 
10/100 Internal PS defaults to IP Address 192.168.254.254.
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Setting the Subnet

To set the subnet, complete these steps: 

1. From the ZebraNet View menu bar, select PrintServer > Configuration.

2. Click the TCP/IP tab.

3. From the Print Server Configuration > TCP/IP tab, in the Subnet Mask text-box, type in 
your subnet mask.

4. Confirm it is accurate, and click OK.

The Print Server Configuration dialog opens.

Figure 14 • Printer Server Configuration

5. To set a permanent IP address, enable the Set Permanent option button.

6. In the Set Permanent text box, type a new IP address, and then click OK.
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Setting the Default Gateway

These steps are optional.

To set the default gateway, complete these steps: 

1. From the ZebraNet View menu bar, select PrintServer > Configuration.

2. Click the TCP/IP tab.

3. From the Print Server Configuration > TCP/IP tab, in the Default Gateway text-box, type 
in your default gateway.

4. Confirm it is accurate, and click OK.

In a Non-Windows Environment

These steps can be used to assign an IP address using the control panel (LCD).

Assigning an IP address from the printer LCD

To assign an IP address from the printer LCD, complete these steps:

1. Turn on (I) the printer and wait until the LCD says PRINTER READY. If you do not have 
a network cable in the port, the 10/100 Internal PS prints the configuration label when it is 
ready.

2. On the printer control panel, press SETUP/EXIT.

3. On the printer control panel, press PREVIOUS until you reach the NETWORK SETTINGS 
menu item. 

4. You can edit any of the following network settings in order to communicate with any 
10/100 Internal PS in your network environment.

• ip resolution (dynamic, permanent): The printer menu item IP RESOLUTION must 
be set to PERMANENT if attempting to assign the IP address from the control panel.

• default gateway (default setting of 000.000.000.000) 

• subnet mask (default setting 255.255.255.0) 

• ip address (if initial default setting is 0.0.0.0, after 2 minutes this defaults to 
192.168.254.254)

• ip protocol (gleaning only, RARP, BOOTP, DHCP, DHCP and BOOTP, all) 

Important • To change any of these settings, you need to enter the printer password. The 
default password is 1234.
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Assigning an IP Address via a Telnet Session 

If your environment is not Windows-based, this section is for you. However, this method can 
be used in a Windows environment, too.

The methods used for assigning an IP address with a Telnet session are Static Route and 
Gleaning.

 

Before you can Telnet to the 10/100 Internal PS and configure it, you must first assign the 
10/100 Internal PS a temporary IP address. 

Static Route

To use this method, complete these steps: 

1. Turn on (I) the printer and wait for 2 minutes to allow for the device to complete the 
self-test. 
During this time, the 10/100 Internal PS performs an address broadcast. If no address is 
assigned to the unit (via DHCP or Bootp), it uses a default address. The default address for 
10/100 Internal PS is 192.168.254.254. Print the 10/100 Internal PS configuration 
label to confirm the address. For details, see Before You Begin on page 34.

2. You can use the route add command to place the default IP address into the 
workstation's network routing table.

 

3. At the workstation/host command prompt (in Windows, at the DOS prompt), type:
route add **** "IP address of the workstation" 0

4. Telnet to the 10/100 Internal PS by typing:
"Telnet xxx.xxx.xxx.xxx" 
The password is 1234. 

5. At this point, you can alter the settings as desired. When complete, do a reset and allow 
the 10/100 Internal PS self-test to complete before proceeding with any communications 
activity. 

Important • This applies to any TCP/IP-capable workstation/host networked with the Zebra 
printer. Both, the workstation/host and the 10/100 Internal PS, must be on the same network 
segment.

Example • In the next step, **** is the IP address on the 10/100 Internal PS 
configuration label.

Note • The zero (0) placed at the end of the “route add” command is optional on some 
systems. 
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Gleaning

A method by which the 10/100 Internal PS uses the IP address of the first ping packet that is 
sent to its hardware address.

To use this method, complete these steps: 

1. Add an entry to the ARP table that assigns an IP address to an Ethernet (hardware) 
address. 
The syntax for this command is: 
arp -s "temporary ipaddress of print server" "MAC Address 
(print server hardware address)" arp -s <temporary ip 
address> <MAC Address>

 

2. Power cycle the printer. 

3. As the printer reboots, begin a continuous ping to the address assigned previously. 

4. When the 10/100 Internal PS begins to respond, stop the ping activity.
 In Windows, Ctrl + C halts the pinging.

5. Telnet to the 10/100 Internal PS and assign the appropriate IP address, subnet mask, and 
gateway, if applicable. 

6. Once this is complete, reset the 10/100 Internal PS. 
For details on resetting the 10/100 Internal PS, see Reset on page 30.

Note • Gleaning works only on local subnets at routers. It does not pass Address Resolution 
Protocol (ARP) broadcasts.

Example • You would type:
arp -s 10.3.50.59 00-07-4d-68-1D-B9-86

Note • Most UNIX systems use a continuous ping. 
To use a continuous ping from a Windows host, you must issue the command:
ping -t "ipaddress". 
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4
Installation

This chapter provides information on the 10/100 Internal PS, and how to install ZebraNet 
Utilities and the ZebraNet View Java Applet.
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10/100 Internal PS

The illustrations below show the relative size of the 10/100 internal PS board, the location 
within the ZM400, and a close-up view of the board.

Figure 15 • ZM400 and the 10/100 Internal Print Server

Figure 16 • Close-up View of 10/100 Internal Print Server

Note • To install an 10/100 Internal PS, see the installation instructions on the Connectivity 
Solutions CD.

1 ZM400 printer
2 10/100 Internal Print Server

1 10/100 Internal Print Server
2 Ethernet connector

1

2

1

2
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ZebraNet Utilities
The ZebraNet Utilities is a software suite consisting of tools to assist you with the 
configuration of the 10/100 Internal PS device, which gives you the flexibility to make 
changes to settings, track errors, and more.

If you want to be certain you have the most recent version of the ZebraNet Utilities, you can 
visit our Web site and download the most recent version at:

www.zebra.com/utilities

For more details, see Overview on page 14 or ZebraNet Utilities on page 93. 

To install the ZebraNet Utilities, complete these steps:

The steps that follow reflect the steps and dialogs for a typical installation. If you plan to 
conduct a custom installation, the dialogs you encounter or see will differ from those in these 
steps. 

1. Insert the CD-ROM into the drive.

2. Click Next.
Figure 17 shows the dialog box where you select the utilities that you want to install.

Note • Contact your System Administrator before installing this software. You must have 
Administrator rights on your network to install most of these utilities. 

Important • Is AutoPlay enabled on your computer?
• Yes. Your computer automatically launches the installation.
• No. You need to navigate to:

Software > ZebraNet Util > setup.exe

on the CD-ROM and manually launch the installation.

http://www.zebra.com/utilities
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Figure 17 • ZebraNet Install Utilities

3. In the ZebraNet Utilities dialog, select the features you want to install and click Next. 
Figure 18 gives you the chance to reset your installation settings.

Figure 18 • ZebraNet Setup Dialog

Important • If you choose to install the ZebraNet View Java Applet in step 3, you must 
complete the installation steps for ZebraNet View Java Applet on page 52.

Each of these 
icons has a 
drop-down 
menu from 
which to 
choose.
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4. In the ZebraNet Utilities dialog, you have the option to review and make any changes to 
your installation settings. When you are satisfied with your installation settings, click 
Install. 
When the installation is complete, this dialog opens.

Figure 19 • ZebraNet Setup Dialog

5. Click Finish.

Important • When the installation is complete, you need to restart your system for the changes 
to take effect.
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ZebraNet View Java Applet
If you selected ZebraNet View Java Applet when you were installing the ZebraNet Utilities, 
you need to complete a few installation steps to work with this utility.

To install ZebraNet View Java Applet, complete these steps: 

1. From the task bar, select Programs > ZebraNet Utilities > ZebraNet View Java Applet 1.0.
This Security Warning dialog opens.

Figure 20 • ZebraNet Security Warning

2. To begin the installation, click Yes.
The Select Java Plugin Installation dialog opens.
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Figure 21 • Select Java Plugin Installation

3. Make the selections that apply to your environment, and click Install.
The Software License Agreement opens.

Figure 22 • Software License Agreement

4. Read the License Agreement. 

5. To continue with the installation, click Yes. 
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6. When the installation is complete, click OK. 
The Java page opens.

Figure 23 • Java Page

7. You have these options:

• To work with this utility, see ZebraNet View Java Applet on page 104.

• To close the utility, click the X.
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A
ZebraLink WebView

The appendix provides you with detailed information that allows you to use the enhanced 
functionality of your ZebraLink-enabled printer with the 10/100 Internal PS.
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WebView
WebView provides the System Administrator or user complete, easy, one-step control over the 
printing environment. It provides real-time configuration, control, and monitoring capabilities 
with the convenient graphic interface of a Web browser. 

The Web pages returned by Zebra printers are not static. They contain real-time information 
about the printer’s present state of operation, including on-line status, error conditions, and all 
printing parameters. 

Home Page

The Home Page is the first Web page that opens. It is a page with a menu of hyperlinks. Each 
hyperlink allows you to make modifications to the printer, 10/100 Internal PS, and network 
settings. The other changeable settings on the Home Page include:

• Network Status, Error, and Warning reports

• ZebraNet 10/100 Internal PS configuration

• Printer settings

• Directories of objects stored in Flash memory and RAM devices

• Objects, stored fonts, images, programs, and ZPL II formats

• Zebra Technologies support and home pages

Note • To access the printer’s Web page, you need the IP address. For instructions on getting 
the IP address, see Assigning an IP Address on page 41.
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To open WebView for your printer, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, and press Enter.
The Printer Home Page opens.

Figure 24 • Printer Home Page

View Printer Configuration 

The View Printer Configuration menu option provides accurate, up-to-the-minute information 
on the printer’s current state. An administrator can conveniently find any information on the 
virtual configuration label and also check on the status of printer ports.
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To see the View Printer Configuration menu option, complete these steps:

1. From the Printer Home Page, click View Printer Configuration.
The WebView displays the configuration settings.

Figure 25 • Configuration Settings
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2. To update the printer information from this view, click Refresh and the printer sends 
current information to the Web browser.

3. When you are finished reviewing:

If... Then...

You want to return to the Home page Click the Home link.
You want to print a label Scroll to the bottom of this page and click Print 

Label.
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Print Server Settings

This section provides you with instructions for viewing the current printer settings.

To view the print server menu, complete these steps:
• From the Printer Home Page, click Print Server Settings.

 The Print Server Settings Page opens.

Figure 26 • Print Server Settings Page
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View and Modify Printer Settings

This section provides you with steps for accessing and modifying printer settings with a 
ZebraLink-enabled printer. It also provides illustrations of the various pages you can access.

Important • To apply changes made in this section, you need to use the default password for 
your printer:

Password: 1234
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To view and modify printer settings, complete these steps:

1. From the Printer Home Page, click View and Modify Printer Settings.
The View and Modify Printer Settings page opens.

Figure 27 • View and Modify Printer Settings
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2. On the View and Modify Printer Settings page, you have a menu to choose from. Table 5 
identifies each menu option page.

Table 5 • Menu Options

General Setup

Serial Communications Setup
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Network Configuration

Print Listings on Label

Table 5 • Menu Options (Continued)
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Media Setup

Calibration

Table 5 • Menu Options (Continued)
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ZPL Control

Advanced Setup

Table 5 • Menu Options (Continued)
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Setting the Primary Network Print Server

The ZM400 and ZM600 printers support the simultaneous installation of an internal, external, 
and a wireless print server. Even though all three print servers may be installed, only one is 
connected to the network and is the active print server. Table 6 outlines priorities and identifies 
which device becomes the active print server when multiple print servers are installed.

Table 6 • Primary Print Server

This section provides you with steps for changing the primary network.

To change the primary network, complete these steps:

1. From the Printer Home Page, click View and Modify Printer Settings.
The View and Modify Printer Settings page opens.

If the 
Primary
Network 

is set 
to:

Installed and Connected to a Live 
Ethernet Network Then, the 

Active Print 
Server will be:Internal External Wireless*

Wired
X X X Internal

X X External
X Wireless

Wireless
X X X Wireless
X X Internal

X External
*NOTE: A Wireless Option board must have an active radio that can properly associate to an 
access point.
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Figure 28 • View and Modify Printer Settings

2. When prompted, enter the printer’s password.

Important • To apply changes made in this section, you need to use the default password for 
your printer:

Password: 1234
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3. Click Network Configuration.
The Network Configuration page opens.

Figure 29 • Network Configuration Page

4. Click Primary/Secondary Settings.

Figure 30 opens.
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Figure 30 • Primary/Secondary Settings Page

5. If you wish to load network settings from the external print server, click YES.

6. To change the primary network, click on the Primary Network drop-down. Select either 
Wired or Wireless print server as your primary network.
Table 6 outlines priorities and identifies which device becomes the active print server 
when multiple print servers are installed.

7. Click Submit Changes to apply your changes or click Reset Changes to revert back to 
previous settings.
Figure 31 opens to confirm your settings have been temporarily saved.
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Figure 31 • Primary/Secondary Settings Saved

8. Click on View and Modify Printer Settings link.

9. From the View and Modify Printer Settings page, click on Save Current Configuration.

This will permanently save your settings.

TCP/IP Settings

TCP/IP settings may be viewed and modified in this section. Several of these settings include:

• IP Address

• IP Protocol

• Subnet mask

• Default gateway
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To change the TCP/IP settings, complete these steps:

1. From the Printer Home Page, click View and Modify Printer Settings.
The View and Modify Printer Settings page opens.

Figure 32 • View and Modify Printer Settings

2. Click on Network Configuration.
The Network Configuration page opens.
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Figure 33 • Network Configuration Page

3. Click TCP/IP Settings.
Figure 34 opens.
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Figure 34 • TCP/IP Settings Page

4. From the TCP/IP Settings page, you can modify settings for all installed print servers.

5. Click Submit Changes to accept and save your changes or click Reset Changes to revert 
to your previous settings.

Note • The ZM400 and ZM600 printers support the simultaneous installation of an 
internal, external, and a wireless print server. See Table 6 on page 67 for more detailed 
information on priorities and setting the active print server when multiple print servers are 
present.
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Printer Controls

This page offers control over basic printer functions. 

Other functions are also accessible from this page. These include:

• Feed — causes printer to feed one label.

• Cancel One Format — cancels the currently printing format.

• Cancel All Formats — cancels all formats.

• Reset Printer — causes printer to perform its standard reset without cycling power. 

To view Printer Controls, complete these steps:

1. From the Printer Home Page, click Printer Controls.
This Printer Controls page opens.

Figure 35 • Printer Controls

Important • In this view, you must have administrative rights to make changes to the printer 
controls. 
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Directory Listing 

The directory page provides a listing of all file system devices (B:, E:, R:, Z:). The size, name, 
and location of each stored object appears.

Buttons are available to perform file management operations on the objects. The file 
management operations include:

• Delete object — Not available for objects in read-only memory (Z:).

• Copy object to a new name and/or device — Not available for objects in read-only 
memory (Z:).

To view the Directory Listing, complete these steps:

1. From the Printer Home Page, click Directory Listing.
This page opens.

Figure 36 • Directory Listing
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2. There are several fields to select in this view. 

3. To create a script, click Create New Script.

Alert Setup
To configure the printer’s interaction with ZebraNet Alert to be completely functional, SNMP 
settings must be established in these areas:

• The printer, via the WebView interface.

• The Alert Printer Management Utility for logging SNMP traps.

The ZebraLink messaging system provides for more than SNMP notification. Alerts can be 
routed to various destinations:

• TCP

• UDP

• email

• serial port

• parallel port destinations
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Setting Alerts 

Your 10/100 Internal Print Server allows you to configure your printer to send unsolicited 
Alerts.

Table 7 shows the conditions that can trigger alerts.

This section has step-by-step instructions for setting up an alert using ZebraLink™. For 
information on setting up alerts using ZebraNet View, see ZebraNet Utilities on page 93. 

Table 7 •  Alerts

Alert Type Error Condition

ZebraLink Alerts • Media out
• Ribbon out
• Printhead over-temp warning
• Printhead under-temp warning
• Head open
• Power supply over-temp
• Ribbon warning (in direct-thermal mode)
• Rewind full
• Cut error
• Printer paused
• PQ job completed
• Label taken
• Head element out
• Power on

Important • If you do not have a ZebraLink-enabled printer, these steps will not work. 
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To view Alert Setup using ZebraLink, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, and press Enter.
The Printer Home Page dialog opens.

Figure 37 • Printer Home Page
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3. From the Printer Home Page, click Alert Setup.
The Alert Messaging System dialog opens.

Figure 38 • Alert Messaging System

To add an alert, you need the default password.

4. To add an alert, click Add Alert Message.

5. Select accordingly.

6. You can use ZebraNet Alert to monitor alerts set through a ZebraLink-enabled printer.
From this Web page, you can add alert messages notifying you when a printer is out of 
paper, needs a ribbon, and so on.
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Establishing Email Alert Messaging 

You can have multiple email addresses set up for routing different error messages, or split 
notifications between email and other network management tools. 

To begin receiving email notification of errors, complete these steps:

1. Open a Web browser.

2. In the Address text-box, type in the printer’s IP address. 
The Printer Home Page opens.

Figure 39 • Printer Home Page

3. From the Printer Home Page, click Alert Setup.
The Alert Setup page shows a list of message notifications and their respective 
destinations (if no notifications are listed). 

4. To set up email notification, go to the Alert Setup page and click Add Alert Message.
.

Important • The printer accepts only the last configuration made.
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The Add Alert Message page opens.

Figure 40 • Add Alert Message

5. Specify the condition to send over email, such as HEAD ELEMENT BAD or PAPER OUT.

6. Set Destination to Email.

7. In the SET drop-down box, select YES.
You will be notified via email whenever your specific condition is detected.

8. In the CLR drop-down box, select YES if you wish to be notified when the specific 
condition is cleared.
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9. Enter a valid email address to send the alert messages to.

10. Click Add Alert Message. 
To receive email alert, you must give 10/100 Internal PS the IP address of your mail server 
that is running SMTP.

11. To save current settings, click Save Printer Setting. 

12. Enter the password and click Save Current Configuration.

13. You can continue to add more Alerts, if finished:

• From the Printer Home Page, select PrintServer Settings > Network Communications 
Setup. 

• Click SMTP Email Alerts.   

• Specify your SMTP server address. 

When these steps are done, you can begin receiving email notification messages.

Example • admin@yourcompany.net (The Port field can be ignored for 
email setup.)

Important • A password is required. If you forget to enter the password, the alerts you just 
set are deleted.

Note • The SMTP Server address might be referred to as Mail Server address.
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Checking 10/100 Internal PS Configuration Settings
This section provides steps on how to check the 10/100 Internal PS configuration settings 
using a browser.

Browser

This section provides steps on how to check the 10/100 Internal PS configuration settings 
using its Web pages.

To access the 10/100 Internal PS settings, complete these steps: 

1. Open a Web browser.

2. In the Address text-box, type your printer’s IP address, then press Enter.
Your browser page looks similar to Figure 41.

Figure 41 • Browser View

3. From the Printer Home Page, click Print Server Settings.
The default User ID and password are required.
The Print Server Settings Page opens.
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Figure 42 • Print Server Settings Page
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To access the 10/100 Internal PS settings, complete these steps: 

1. From the Printer Home page, click Print Server.
The Print Server Configuration page opens.

Figure 43 • Print Server Configuration

2. For details on the configuration choices, see Configuring the Print Server on page 87.
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Configuring the Print Server
This section provides the steps to configure the 10/100 Internal PS using ZebraLink Web and a 
web browser.

To change the TCP/IP Configuration, complete these steps:

1. From the Printer Home page, click Print Server Settings.
The Print Server Configuration page opens.

2. From the Print Server Configuration page, click Print Server.

The Print Server Configuration page opens.

Figure 44 • Print Server Configuration
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3. From the Print Server Configuration page, you have a menu from which to choose. See 
Table 2 on page 24 for more detailed information on these settings.

4. Select the appropriate link to make your change(s).

Sending Email to Your Zebra Printer
To easily transfer instructions and data to your printer from a remote location, the 
10/100 Internal PS allows you to send email to the printer. This is set up under the link POP3 
Email Printing. You need to provide the address of the network POP3 server, a user name, and 
a password. With this option, you can create a text-based email containing ZPL II code and 
transfer it to the printer.

By using the proper ZPL II commands, files can be saved, loaded, printed, copied, and deleted, 
just as if the data were transferred from a serial or parallel port.

Note • Email attachments sent to the printer are not supported.
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To access POP3, complete these steps: 

1. From the Printer Home page, click Print Server Settings.
The Print Server Settings Page opens.

Figure 45 • Print Server Settings Page
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2. From the Print Server Settings Page, click Print Server.
The Print Server Configuration Page opens.

Figure 46 • Print Server Configuration
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3. From the Print Server Configuration page, click POP3 E-mail Printing.
The POP3 Printing Configuration page opens.

Figure 47 • POP3 Printing Configuration

4. Make the necessary changes, and click Submit Changes.
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B
ZebraNet Utilities

The appendix provides you with details on ZebraNet Utilities, the software suite of printer 
administration tools that complements and enhances both ZebraLink and the ZebraNet family 
of connectivity products. 
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ZebraNet View
ZebraNet View offers powerful device management capabilities and allows you to locate 
printers automatically. It can search on parameters such as IP address, subnet, printer model, 
printer status, and many other user-defined characteristics.

To open ZebraNet View Utilities, complete these steps: 

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet View.
The ZebraNet View dialog opens.

Figure 48 • ZebraNet View

2. Select your printer.
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Print Server Configuration
To configure your print server, complete these steps:

1. From the menu bar, select PrintServer > Configuration.
The Print Server Configuration dialog opens.

Figure 49 • Print Server Configuration

There are multiple tabs that you can access to make changes to current settings. 
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ZebraNet Alert 
ZebraNet Alert gives you the ability to manage your Zebra printers by immediately notifying 
System Administrators of printer error or warning conditions, which reduces printer downtime 
and increases application efficiency. Using Web-based configuration tools, selected errors or 
warning conditions can be routed to a variety of services such as email messages, wireless 
pagers, or the ZebraNet Alert.

Table 8 shows the conditions that can trigger alerts and the possible destinations.

Table 8 • ZebraNet Alert and Destinations

Alert Type Error Condition

ZebraLink Alerts • Media out
• Ribbon out
• Printhead over-temp warning
• Printhead under-temp warning
• Head open
• Power supply over-temp
• Ribbon warning (in direct-thermal mode)
• Rewind full
• Cut error
• Printer paused
• PQ job completed
• Label taken
• Head element out
• Power on

ZebraNet Alert 
Destinations 

Unsolicited Alert messages can be directed to the following 
destinations:
• Email (10/100 Internal PS-specific)
• TCP (10/100 Internal PS-specific)
• UDP (10/100 Internal PS-specific)
• SNMP (10/100 Internal PS-specific)
• Serial
• Parallel
• USB
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ZebraNet Alert Using SNMP 

You can send notifications over SNMP only, for use with ZebraNet Alert or a similar network 
management utility. 

To configure the 10/100 Internal PS to send alerts across a TCP/IP Network 
using ZebraNet Alert, complete these steps:

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet View.

2. Select the printer you want.

3. To assign your printer an IP address, from the menu bar, select Print Server > 
Configuration.

4. For PrintServer SNMP Traps, select the SNMP Traps tab.

5. Enter the trap destination and options.
This tells the 10/100 Internal PS what TCP/IP address to send the alerts to, and under what 
circumstances to send error and log reports. Entering 255.255.255.255 broadcasts the 
message to every host on the network with an SNMP program running.

6. For ZebraNet Alert to get and display the messages, you need to open ZebraNet Alert. To 
do this, follow these steps:
a. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet Alert.

b. In the ZebraNet Alert dialog, from the menu bar, select View > Filter Settings. 
c. From the View Filter - Devices tab, choose your settings accordingly. 

d. The View Filter - Events tab allows you to select individual events you want the 
program to be aware of.

.

Important • If you did not install ZebraNet Alert during the ZebraNet Utilities installation, see 
ZebraNet Utilities on page 49.

If... Then...

A DHCP server is 
present

The 10/100 Internal PS will already have an IP address.

No DHCP server is 
present

You may need to assign the printer an IP address.

Important • The SNMP trap settings must be established to communicate with 
10/100 Internal PS if messages are sent to the ZebraNet Alert.

Note • If you select No device filtering, messages from every printer are caught; 
Device Address allows you to specify from which IP address data will come.

Important • Now SNMP Alert messages for the 10/100 Internal PS can be set up in 
WebView. From the printer’s home page, activate the link to Alert Setup. You can add 
messages that are sent to the ZebraNet Alert for Windows by choosing SNMP as a 
destination.
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Open ZebraNet Alert

To open ZebraNet Alert, complete these steps:

1. From the task bar, select Start > ZebraNet Utilities > ZebraNet Alert.

2. In the ZebraNet Alert dialog, from the menu bar, select Report. 
The report menu option has multiple report selections.

3. Select the type of report you want to generate.
Table 50 is an example of the Event Summary report. Notice it generates a .log file.

Figure 50 • Event Summary Report
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Setting Alerts 
This section includes step-by-step instructions for setting up an alert using ZebraNet View. For 
information on setting up alerts using ZebraLink, see ZebraLink WebView on page 55.

To set alerts (traps) using ZebraNet View, complete these steps:

1. In the ZebraNet View dialog, from the menu bar select Print Server > Configuration.

2. Click the SNMP Traps tab.
The Printer Traps check boxes are the alerts you can set from ZebraNet View.

Figure 51 • SNMP Traps
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3. Enable the alerts (printer traps) you want to set here and click OK.

4. To monitor the alerts you established, from the task bar select Start > ZebraNet Utilities > 
ZebraNet Alert.
The ZebraNet Alert dialog opens.

Figure 52 • ZebraNet Alert

In this dialog you can view the log of errors and monitor the activity of your printer(s).
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Establishing Email Alert Messaging 

ZebraNet Alert supports email notification of printer errors sent directly to any valid email 
address. You can have multiple email addresses set up for routing different error messages, or 
split notifications between email and other network management tools. 

To monitor alerts, complete these steps: 

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet Alert.
The Active Log dialog opens, displaying a list of all the logged alerts.

Figure 53 • Active Log Dialog

2. From this dialog, you can track the printer(s) activity and status. 

3. From the menu bar, you can explore all of the other features, such as Reports.
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Checking 10/100 Internal PS Configuration Settings
This section provides steps on how to check the 10/100 Internal PS configuration settings 
using ZebraNet View.

To check configuration settings, complete these steps: 

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet View.
The ZebraNet View dialog opens. 

Figure 54 • ZebraNet View



103ZebraNet Utilities
Checking 10/100 Internal PS Configuration Settings

04/19/2007 ZebraNet® 10/100 Internal Print Server for ZM400 and ZM600 User Guide 14197L-001 Rev. A

2. From the menu bar, select Print Server > Configuration.
The Print Server Configuration dialog opens: 

Figure 55 • Print Server Configuration

This dialog offers multiple tabs from which to choose. Each tab contains various configuration 
settings that you can change.

For details on the configurations, see Print Server Configuration on page 95.
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ZebraNet View Java Applet 
ZebraNet View Java Applet is a Java-based version of ZebraNet View. This can run on any 
enabled platform that can run a Java virtual machine, such as Windows, UNIX, Linux, and 
many others.

 

To access ZebraNet View Java Applet, complete these steps: 

1. From the task bar, select Start > Programs > ZebraNet Utilities > ZebraNet View Java 
Applet 1.0.
This dialog opens.

Figure 56 • ZebraNet View Java Applet 1.0

Important • To use ZebraNet View Java Applet, you must have installed ZebraNet Utilities 
and then installed this application. For installation instructions for ZebraNet Utilities, see 
ZebraNet View Java Applet on page 52.
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2. In the Search Method drop-down box, select the search method you want.

3. Click Begin Search.
It searches your network for all networked Zebra printers, discovers them, and lists them.

4. When you select a device from the discovery list, the selected device’s Home Page 
appears in the lower portion of the view (it replaces the ZebraNet View Web 
Configuration Utility content).
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ZebraNet Connect IP
ZebraNet Connect IP allows you to send jobs to print servers that use Dynamic IP addresses 
(DHCP). It also notifies you of printer errors, such as paper out or head open. When 
print jobs are printed through ZebraNet Connect IP, they are sent directly to 10/100 Internal PS 
and are not routed through a network server, resulting in a reduction of network traffic.

Setting up a ZebraNet Connect IP 

If you have printing problems while using the ZebraNet Connect IP printing port, you may 
check the status of the port or change its settings through the printer Properties dialog.

• For Windows 95/98, select Port Settings under the Details tab.

• For Windows NT 4.0 or Windows 2000, select Configure Port under the Ports tab.

Windows NT 4.0/Windows 2000 

If you are using the Windows NT 4.0 or Windows 2000 operating system, use the following 
procedure to set up a printer port for the 10/100 Internal PS.

To set up a printer port for the 10/100 Internal PS, complete these steps:

1. From the task bar, select Start > Settings > Printers.

2. Select the Windows printer to use when printing with the 10/100 Internal PS.

3. From the menu bar, select File > Properties.

4. To add a ZebraNet Connect IP port, in the Ports tab select Add Port.

5. From the list of Available Printer Ports, select ZebraNet Connect Monitor as the type of 
port to add, and click New Port.

From the Add ZebraNet Connect Port screen, there is a list of all 10/100 Internal PS 
devices available on the local subnet.

• The TCP/IP monitor searches only the local subnet.

Note • The DHCP feature of ZebraNet Connect IP can rediscover a 10/100 Internal PS on the 
local subnet, even when its IP address might be changing (for example, when using DHCP for 
IP address resolution). The 10/100 Internal PS is relocated by its port name as configured 
through ZebraNet View (the default name is Serial Number-Port Number). This feature is 
enabled on the local subnet only. A non-local 10/100 Internal PS device is not rediscovered if 
the IP address changes.

Note • If ZebraNet Connect IP monitor is not listed, verify that the ZebraNet Connect IP 
software has been properly installed. To do this, you need to reinstall the software and 
choose Modify.
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6. If the port you want to add is listed in the Ports Available on Local Subnet window, select 
the port name. If the port you want to use is not listed, you can: 

• Select Cancel and repeat step 5 to rediscover the print servers. 

• In ZebraNet Connect, click the Locate Non-local Device button and enter the static 
TCP/IP Address used for the 10/100 Internal PS.

7. Click Add.

8. To close the Printer Ports dialog, click Cancel.

9. To save the configuration, click OK.

Now you can use ZebraNet Connect. Whenever you print to the Windows printer configured 
with ZebraNet Connect, your print job will go directly to the ZebraNet 10/100 Internal PS 
port.

Windows 95/98/Me 

To set up a 10/100 Internal PS port using Windows 95/Windows 98/Me, complete 
these steps:

1. From the task bar, select Start > Settings > Printers.

2. Select the Windows printer that you want to print with ZebraNet Connect IP.

3. From the file menu, select File > Properties.

4. To add a ZebraNet Connect IP port, in the Details tab select Add Port.

5. From the Add Port dialog, select Other, then select the ZebraNet Connect Monitor as the 
type of port to add. 

6. Click OK.
The Add ZebraNet Connect Port screen opens. There is a list of all 10/100 Internal PS 
devices discovered on the network.

• The TCP/IP monitor searches only the local subnet.

Note • The ZebraNet Connect for TCP/IP DHCP discovery feature relocates a 
10/100 Internal PS device on the local subnet by its port name, even if the IP address 
changes. This feature is enabled on the local subnet only. A non-local 10/100 Internal PS 
device is not rediscovered if the IP address changes.

Note • Under Windows 95, you have to set up the printer for a local port first, then open 
Properties from the File menu and continue with the configurations.

Note • If ZebraNet Connect IP is not listed, verify that the software has been properly 
installed.
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7. If the port you want to add is listed in the Ports Available on Local Subnet window, select 
the port name. If the port you want to use is not listed, you can:

• Select Cancel and repeat step 5 to rediscover the 10/100 Internal PS devices. 

• In ZebraNet Connect IP, click the Locate Non-local Device button and enter the static 
TCP/IP address used for the 10/100 Internal PS.

8. Click Add.

9. To save the configuration, click OK.

Now you can use ZebraNet Connect IP. Whenever you print to the Windows printer 
configured with ZebraNet Connect IP, your print job will go directly to the 10/100 Internal PS 
port.
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C
Hardware Troubleshooting

This appendix provides you with solutions to known issues.
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Troubleshooting the 10/100 PS

Defaulting the 10/100 PS 

To default the 10/100 Internal PS to factory settings using the control panel, 
complete these steps:

1. From the control panel, press Setup/Exit two times.

2. Press Plus (+ key) five times.
The control panel will read DEFAULT NET.

3. Press Setup/Exit to save the change.

4. After the printer defaults all settings, the control panel will show PRINTER READY.

10/100 Internal PS Network Status/Activity Indicator

A single LED containing a red element and a green element. By turning on and off different 
combinations of these two LED elements indicate Ethernet links, activity, and speed.

ZebraNet View Utility Discovery or Configuration Problems

If you are having problems using the ZebraNet View utility to discover or configure the unit, 
check the following:

• Verify there is not a router between the workstation running ZebraNet View and the 
10/100 Internal PS. Because the 10/100 Internal PS does not have an IP address, TCP/IP 
communication cannot be started across a router. Run ZebraNet View on the same subnet 
as the 10/100 Internal PS. 

• Verify that the LED on the 10/100 Internal PS is active. Consult the chart above for 
details. 

LED State Description

Off No Ethernet link detected
Green 100 Mbps link detected
Green, flickering off and on 100 Mbps link detected and Ethernet activity detected
Amber 10 Mbps link detected
Amber, flickering off and on 10 Mbps link detected and Ethernet activity detected
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Unable to Print 

If you are having problems printing, verify that there is communication between the 
10/100 Internal PS and the printer. Suggestions include the following:

• Ping the printer to determine the ability to communicate with the printer. See Ping the 
Printer.

• Or open a Telnet session and send a ZPL command to print a configuration label. See 
Telnet on page 112 for more information.

• Check obvious error conditions such as head open, out of media, out of ribbon, etc.

• If problems persist, contact Technical Support.

Ping the Printer

To ping the printer, complete these steps:

1. Open a DOS window. 
To open a DOS window, click on Start > Run.

2. In the Open text box, type: cmd 

3. From the DOS prompt, type:
ping xxx.xxx.xxx.xxx
where xxx.xxx.xxx.xxx is the IP address of the print server

4. See Figure 57. You see a reply from the print server indicating a connection.

Figure 57 • Example of a Successful Ping

If the issue is a communication problem, you would have received an error message.
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Telnet

Open a telnet session to send a ZPL command from a DOS prompt. This procedure can be 
used when running v53.15 or later firmware. In this example, a ZPL II command is used to 
cause a label to print. 

To open a telnet session on your PC, complete these steps:

1. Open a DOS window. 
To open a DOS window, click on Start > Run.

2. In the Open text box, type: cmd 

3. From the DOS prompt, type:
telnet xxx.xxx.xxx.xxx 9100
where xxx.xxx.xxx.xxx is the IP address of the print server. 

This will connect your PC to the 10/100 Internal PS through the parallel port of the printer.

4. Enter ~WC.
This ZPL command will print a configuration label on your printer.

5. Click the X in the upper right-hand corner of the window to exit.

If the configuration label prints, the issue is not a communication problem between the printer, 
the print server, or the PC.

Unable to Configure Device 

To assign an IP address to a ZebraNet 10/100 Internal PS using ZebraNet View, you must be 
on the same subnet. If ZebraNet View has Multicast enabled, you may be able to view the 
ZebraNet 10/100 Internal PS on another subnet, but you will not be able to configure the 
device.

Note • You do not need to open a telnet session if you pinged the printer using the previous 
procedure. The purpose of these two procedures is to identify whether your PC can 
communicate with your printer.
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D
Print Protocols

In this appendix, an exercise is provided to experiment with File Transfer Protocol (FTP) 
support.
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FTP 
Embedded within the 10/100 Internal PS is an FTP server application that processes file 
transfers from a host computer to the printer.

If the printer is on a network, label formats can be generated and data can be transferred 
without setting up a print queue.

To send information to the printer in a Windows environment, try this exercise: 

1. In a text editor, generate the following ZPL II code:
^XA

^FO100,100

^CF0,55^FDZebra Technologies^FS

^XZ

2. Save the file and name it test.txt.

3. Open the MS-DOS Command Prompt and type:
ftp <IP of 10/100 PS>

This opens a session with the FTP server. 

4. Type your user name and press Enter.

5. Type:
put test.txt

This transfers test.txt to the printer, and the printer generates a label.

6. To terminate the FTP session, type:
quit

Example • If the IP address of your 10/100 Internal PS device is 12.3.4.123, you 
would type:

ftp 12.3.4.123

Note • The default user name is blank.
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E
Print Queues

This appendix provides information and instructions on configuring your print queue.
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Berkeley Software Distribution (BSD)-Style Print Queue
BSD is a version of the UNIX OS that includes TCP/IP.

Configuring the Print Queue

For remote BSD-style LPD printing, add the 10/100 Internal PS as a remote printer in the 
/etc/printcap database to each host printing to the 10/100 Internal PS. You can add printcap 
options as needed. If you are unfamiliar with these options, consult the printer documentation. 

The entry looks similar to this:
local_print_queue_name|[printer_model_and_manufacturer]:\

:lp=:mx#0:rm=ZebraNet_name:\

:rp=remote_print_queue_name:\

:sd=path_to_spool_directory:lf=just log_file_name

local_print_queue_name — This defines the name of the printcap entry. It is used by 
the LPR/LPD utilities to specify which printcap entry is being referenced. Additional printcap 
entries can be added as needed for different queue types. Each entry must have a unique 
local_print_queue_name and a different spool directory to work properly. When you are ready 
to print, use the local_print_queue_name that matches the data type of the file to be printed.

ZebraNet_name — This is the name (alias) of the ZebraNet 10/100 Internal PS. This must 
be the same name as entered in the /etc/ hosts file or your NIS or DNS system. An IP 
address may also be used here.

remote_print_queue_name — This entry determines the ZebraNet port where the print 
job will be printed and optionally specifies ASCII printing that must end for LF1.

path_to_spool_directory — This is the path to a directory where the print jobs will 
be spooled for this queue. You must create a unique spool directory for each printcap entry.

log_file_name — This is the path to a file where error information from the LPD will be 
logged. 

Important • You must be logged in as root.

Example • Your printcap entries might look similar to this:
Ascii_files|form.feed.Queue_on_Port_1:\

:lp=:mx#0:rm=pserver1:rp=MYQUEUELF1:\

:sd=/usr/spool/myqueuelf1:\

:lf=/usr/spool/myqueuelf1/queue.log

Important • Each printcap entry must have a different spool directory to work properly.
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System V Queue Installation

Configuring Operating System V Queue for ZebraNet Printing

This section describes the configuration of the printing system on the UNIX operating system. 
For clarity and brevity, the following specific names are used to represent general devices or 
concepts. 

lj4 — The local queue name on the UNIX system to which you want 10/100 Internal PS 
print jobs directed.

ZEBRAPRINTER — The host name or IP address of the remote system that is the 
10/100 Internal PS device. For example, to Telnet to the 10/100 Internal PS and invoke the 
10/100 Internal PS configuration utility, you would enter: 

Telnet ZEBRAPRINTER

A host name is not required for the 10/100 Internal PS — the IP address can be used. 

yourqueuename — This is the name of the queue on the ZebraNet and must end with LF1.

Prerequisites   

Before you proceed, the following prerequisites must be met: 

• The name ZEBRAPRINTER and the IP address assigned to the 10/100 Internal PS are in 
the /etc/hosts file on the UNIX system.

• The LPD must be running on the UNIX system.

Spool Print Job Configuration

To configure the UNIX machine so users can spool print jobs to the PCL print 
queue on the ZebraNet named ZEBRAPRINTER, complete these steps: 

1. Log in to the UNIX machine as root. 

2. Type:
lpsystem -t bsd ZEBRAPRINTER

3. Type:
lpadmin -p lj4 -s ZEBRAPRINTER!yourqueuename - I any

4. Type:
accept lj4

5. Type:
enable lj4

6. Try printing by typing the command:
lp -d lj4 [filename]
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F
Frequently Asked Questions

This appendix provides a group of frequently asked questions (FAQs) about 10/100 Internal 
PS.

FAQs
Can the ZebraNet 10/100 Internal PS option work on a computer network that is 
running both TCP/IP and IPX protocols simultaneously?  Yes. The ZebraNet 
10/100 Internal PS runs all of its available protocols simultaneously. This means that the 
ZebraNet 10/100 Internal PS can run on mixed networks such as a network using Microsoft, 
and UNIX.

Will the ZebraNet 10/100 Internal PS allow connectivity to anything other than a 
PC network?  Yes. The ZebraNet 10/100 Internal PS allows connectivity to systems such as 
IBM’s AS400, provided that it is configured using TCP/IP.

What if a print job makes it to the queue, but never leaves the queue? The label 
does not print.   These are the things to check:

• Confirm that the printer is turned on and receiving power. 

• Confirm that the network cable is plugged in and that you can ping the printer.

• If the previous bullets do not change the outcome, it is likely that there was a 
misconfiguration while creating the queue. The queue must be recreated verifying the 
following:

• Confirm that you use the print server’s valid IP address. 

• If you are using a UNIX or AS/400 host, there is an option for the remote queue name. 
There is only one valid response to use: PORTLF1.

Important • The ZebraNet 10/100 Internal PS does not support IPX, but it can function on 
networks that use IPX protocols.
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• If Windows does not have LPR installed, the above required option should be left 
blank.

• See the documentation for other operating system specific queue creation.   

What are the minimum requirements to network a printer?  

• Cat-5 network cable with 10BaseT connectors

• 10/100 Internal PS

• Hub or Switch

• If a hub or switch is NOT used, you need a cross-over cable.

• Workstation running a TCP stack with print services installed.

What is the default User ID and password for the print server?  

• The User ID is admin and the password is 1234.

What ports are open on 10/100 Internal PS and related software?  

TCP Ports:

• 21 FTP

• 23 Telnet

• 80 HTTP Server

• 515 Printer port

• 9100 Raw socket connection

UDP Ports:

• 161 SNMP broadcast from 10/100 Internal PS

• 162 SNMP trap on ZebraNet Alert

• 4201 discovery destination on 10/100 Internal PS

• (dynamic) SNMP get request from ZebraNet View

• (dynamic) discovery broadcast from ZebraNet View

• (dynamic) discovery broadcast from ZebraNet View Java
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What are my network connectivity options based on when using a 
10/100 Internal PS?   
It depends on your environment, but the print server accepts print jobs in any of the following 
ways:

• FTP — ZPL/EPL files can be sent to the printer as standard ASCII files via an FTP client.

• HTTP — Using the script option on the printers Directory web page, you can type ZPL 
into a specified location of the Web browser and send it to the printer. 

• LPR/LPD — Sometimes referred to as queue-based printing. LPR/LPD is the standard in 
network printing. Most TCP/IP operating systems are compatible with this option.

• Raw socket connection — You can connect to the printer directly via the network, 
bypassing everything in between. This option is commonly used to integrate ZPL/EPL into 
existing programs, such as VB scripts.

• POP3 — With proper configuration, you can place valid label format instructions into the 
body of an email, and it will print. The print server periodically checks this email box at 
the specified intervals and prints the body of the message.
IMPORTANT: Attachments and subject lines are not supported.
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Glossary

10BaseT   A type of Ethernet that uses unshielded twisted pair cable.

100BaseT   A type of Ethernet that can transmit 100Mb of data per second with a 
twisted-pair cable.

ARP   The standard TCP/IP method for determining the actual network address of a device 
based on its IP address. 

ASCII   A standard for the binary representation of characters. 

BOOTP  BOOTP (Bootstrap Protocol) is a protocol that lets a network client configure 
automatically. It can automatically configure any of the following information: IP address, 
gateway, subnet, system name, name server, and more. It automatically assigns the necessary 
settings from a pool of pre-determined addresses for a certain duration of time. BOOTP is the 
basis for a more advanced network manager protocol, the DHCP (Dynamic Host 
Configuration Protocol). 

broadcast  In a network, a situation when all destinations on the network receive a given 
packet. 

client   A workstation or PC in a client/server environment. 

community  For SNMP, a relationship between an agent and a set of SNMP managers that 
defines security characteristics. The community concept is a local one, defined at the agent. 
Each community is given a unique community name. 

current mode (parallel port)  A mode that the printer and print server negotiate. 

DHCP (Dynamic Host Configuration Protocol)   DHCP is an alternative to another 
network IP management protocol, Bootstrap Protocol (BOOTP). Like BOOTP, DHCP can 
configure an IP address, gateway, subnet, system name, and name server. When speaking 
about the 10/100 Internal PS, BOOTP, and DHCP configure the same options.
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delete bytes  This number is used to remove characters from the beginning of every job sent 
to the logical printer. The value for delete bytes can range from 0 to 255. 

dynamic  A dynamic configuration, as the name implies, means that it changes. BOOTP and 
DHCP offer time-based leases for the configurations they assign. Their changes depend on the 
time-based lease, and how often the printer itself is offline and online again. A dynamic 
configuration can include BOOTP or DHCP. 

Ethernet  A widely used local area network system based on the IEEE 802.3 standard. 

firmware  Software routines that are stored in ROM (Read Only Memory). This is typically 
part of a device, such as a printer or 10/100 Internal PS. 

FTP  File Transfer Protocol, a TCP/IP-related protocol for transferring files between devices 
on a network. 

Flash memory  A type of memory that allows read-and-write operations, but permanently 
stores data when the power is turned off. Useful for storing firmware because it can be easily 
updated by downloading new code. 

gateway  A device that converts one higher-level network protocol to a different higher level 
protocol. 

gleaning  A temporary, local configuration option. Gleaning lets you add the address of the 
device you want to configure to your local workstation’s ARP table. This configuration is not 
permanent and is valid only from the workstation from which you entered the ARP 
information. After the information is entered into the workstation’s ARP table, the user 
follows up with a Telnet session to enter the information permanently. This configuration 
option is used mostly by non-Windows workstations that cannot run the ZebraNet View 
configuration utility. 

IP  Internet Protocol, a packet-based protocol used for delivering data across networks. 

IP address  A network address used by the TCP/IP protocol.

JetAdmin  A Hewlett-Packard printer management program available for NetWare and 
TCP/IP. 

logical  Refers to conceptual rather than physical. For example, a computer might have a 
single physical connection to the network (an Ethernet adapter card), but could have logical 
connections to several other devices on the network. 

LPD   LPD stands for Line Printer Daemon; it is the part that receives and processes the 
request. A "daemon" is a server or agent.

MAC Address  Media Access Control. Ethernet address that corresponds to the assigned IP 
address. 

name server  A workstation on a TCP/IP network that provides a list of all workstations on 
the network. 

node  A device connected to a network, such as a computer or print server.
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parallel port   A port on a device that sends information in groups of bits over multiple 
wires, one wire for each bit in a group. 

ping  A TCP/IP command that determines whether a device is accessible on the network. 

POP3  Post Office Protocol, the protocol used to retrieve email from the server. 

port  A physical connector, such as the parallel port, or a logical connection to a device.

post-string  A string that is sent at the end of every job going to the logical printer. 
Maximum 64 characters long.

pre-string  A string that is sent at the beginning of each job that goes to the logical printer. 
Max 64 characters long. 

print server  A device in a network that changes a network protocol into a printer protocol. 

protocol  A method of sending and receiving data between two or more workstations on a 
network, and ensuring that the data is received without errors. 

RARP  Reverse Arp, a standard TCP/IP method of determining a device’s IP address based 
on its Ethernet address. 

raw TCP port  A type of TCP port in which data is passed unmodified to the receiving node. 

RJ45  A type of modular jack connector similar to a telephone connector with up to eight 
wires. Used for 10BaseT Ethernet connections and for serial port connections. 

serial port  On a printer or print server, a port that transfers data one bit at a time. Serial ports 
usually have either a 25-pin, 9-pin “D,” or RJ-45 connector setting mode (parallel port).

A mode that the print server is set to for the highest level of parallel port communications. 

server  A device on a local area network that provides services to client computers on the 
network. 

SMTP  Simple Mail Transfer Protocol, a protocol used to send email messages over the 
Internet. 

SNMP  Simple Network Management Protocol, a protocol for monitoring and controlling 
devices on a network. 

spooling  In printing applications, spooling is the transfer of data to a temporary storage area 
on disk (the print queue) prior to printing. Spooling allows many jobs to be queued to a single 
printer. 

static  Refers to a static IP address. All information is provided by the network administrator. 

subnet mask  A TCP/IP method of dividing a network into several smaller subnetworks. 

TCP/IP  Transmission Control Protocol/Internet Protocol, the de facto standard for Internet 
communications that is widely used on local area networks.
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TCP Port  A method of accessing a TCP/IP service, where a device with a single IP address 
can have multiple TCP ports. 

Telnet  A TCP/IP protocol that allows two devices to communicate over a LAN. 

trap  An unsolicited message sent by an SNMP agent to an SNMP management station. It 
notifies the management station of some unusual event. 

UNIX  A general-purpose computer operating system used on many different kinds of 
computers.

Windows 95 and Windows 98  Microsoft’s PC operating systems that feature built-in 
peer-to-peer networking. 

Windows NT  Microsoft’s multitasking operating system that can be used either as a client or 
as a server. 

Windows 2000  Microsoft’s multitasking operating system that replaces Windows NT; can 
be used as either as a client or as a server. 

ZebraNet PrintServer II  An Ethernet connectivity solution. 

ZebraNet 10/100 Print Server  An Ethernet connectivity solution.

ZebraLink  Allows you to connect and control your bar code printers anywhere and anytime. 

ZPL II  Zebra Programming Language II is a powerful label-definition and printer-control 
language. 
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